But, now, i think only about "-" or "+" in code and in json files.
What type will be more useful?
—
1)
def process_skill_cost(skill):
cost_val = get_affected_attr(cost.base) - get_affected_attr(cost.compare)
def process_skill_cost_reverse(skill):
cost_val2= cost_val1 - ( get_affected_attr(cost.base) - get_affected_attr(cost.compare) )
OR:
2)
def process_skill_cost(skill):
cost_val = get_affected_attr(cost.base) + get_affected_attr(cost.compare)
def process_skill_cost_reverse(skill):
cost_val2= cost_val1 - ( get_affected_attr(cost.base) + get_affected_attr(cost.compare) )
—
Json code above will propertly works with 1).
If use 2) ruby-code, i will need to use "0.02" ("0.01" for mood) instead of "-0.02" ("-0.01" for mood) in compare with wisdom_trait to decrease cost.
It's just a matter of convenience. Eccma can decide for himself which option he likes best.