On a related topic, is it possible to divert a "get noun" action to get a different noun. For example, I have a lot of tests where I do a has_not_created test and if the object has not been created, then I pocket it. However, because of the crap way that pocketing works, I first have to check whether there's room in the inventory. This is a hell of a lot of extra tests and duplicated code that I could put in a generic get handler if I could work out how to handle generic objects or divert to the default get handler.
And no, I do not want objects being dropped on the floor if I don't have room in my inventory.